PAT甲级真题 1039 Course List for Student (25分) C++实现(map + set 存储,set能自动排序)

news/2024/9/28 11:12:12 标签: map, set, 算法, pat, 数据结构
<path stroke-linecap="round" d="M5,0 0,2.5 5,5z" id="raphael-marker-block" style="-webkit-tap-highlight-color: rgba(0, 0, 0, 0);">path>

题目

Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.
Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=40000), the number of students who look for their course lists, and K (<=2500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students Ni (<= 200) are given in a line. Then in the next line, Ni student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.
Output Specification:
For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student’s name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.
Sample Input:
11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9
Sample Output:
ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0

思路

unordered_map<string, set<int> > 来存储学生选课信息,以学生名字为key,以课程号集合为value。

set是自动维护升序排列的,正好符合题意要求。

若用cin、cout,最后一个测试点会超时(即使加上ios::sync_with_stdio(false); cin.tie(0);仍超时),改写成scanf、printf就通过了。
在这里插入图片描述
用到了scanf读string的小技巧:

char buf[5];
scanf("%s", buf);
string name(buf);

代码

#include <iostream>
#include <set>
#include <unordered_map>
using namespace std;

int main(){
    int n, k;
    scanf("%d %d", &n, &k);
    unordered_map<string, set<int> > stu;
    for (int i=0; i<k; i++){
        int course, m;
        scanf("%d %d", &course, &m);
        for (int j=0; j<m; j++){
            char buf[5];
            scanf("%s", buf);
            string name(buf);
            stu[name].insert(course);
        }
    }
    for (int i=0; i<n; i++){
        char buf[5];
        scanf("%s", buf);
        string name(buf);
        printf("%s %d", buf, stu[name].size());
        for (auto it=stu[name].begin(); it!=stu[name].end(); ++it){
            printf(" %d", *it);
        }
        printf("\n");
    }
    return 0;
}


http://www.niftyadmin.cn/n/905880.html

相关文章

ThinkPHP隐藏入口文件的配置方法

Apache服务器默认是没有开启rewrite模块儿的&#xff0c;所以我们访问ThinkPHP站点时的URL路径一般都是像这样的&#xff1a; http://127.0.0.1/index.php/index/article/list.html这里的index.php即为我们的站点入口文件&#xff0c;而为了实现更好的SEO优化&#xff0c;我们有…

java实体类字段自定义_自定义通用Mapper动态传入所需字段名,如果使用java实体类的字段名...

直接贴代码public interface SelectByPrimaryKeyWithFields {SelectProvider(type MySelectProvider.class, method "dynamicSQL")T selectByPrimaryKeytWithFields(Param("id") Object id, Param("fields") String fields);}public String se…

Docker(二):Dockerfile使用介绍

上一篇文章Docker(一)&#xff1a;Docker入门教程介绍了 Docker 基本概念&#xff0c;其中镜像、容器和 Dockerfile 。我们使用 Dockerfile 定义镜像&#xff0c;依赖镜像来运行容器&#xff0c;因此 Dockerfile 是镜像和容器的关键&#xff0c;Dockerfile 可以非常容易的定义镜…

PAT甲级真题 1040 Longest Symmetric String (25分) C++实现(遍历中间点找最长回文串)

题目 Given a string, you are supposed to output the length of the longest symmetric sub-string. For example, given Is PAT&TAP symmetric?, the longest symmetric sub-string is s PAT&TAP s, hence you must output 11. Input Specification: Each input …

java获取密码框密码_用JAVA编写一个简单密码框

只是简单的写出一个界面来&#xff0c;没有添加事件响应。import java.awt.*;public class Main {public static void main(String[] args) {Frame f new Frame("Password");f.setLayout(null);f.setBounds(500, 500, 300, 220);f.setBackground(Color.WHITE);Label…

7.数组

知识回顾 以前学习过变量,我们知道变量可根据需要存储不同的数据,但是它在同一时间只能存储一个数据如果程序需要在同一时间处理多个数据,如果只用变量,就需要定义很多的变量,效率不高,数组就可以解决此问题了什么是数组 相同数据类型的数据集合分类 一维数组二维数组(实际上还…

PAT甲级真题 1041 Be Unique (20分) C++实现(unordered_map统计元素个数)

题目 Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1, 104]. The first one who bets on a unique number wins. For example, if there are 7 …

java数据库自动生成代码_Mybatis-generator自动生成代码工具嵌入Maven项目中,实现一键生成数据库表对应的java、xml文件...

Maven项目中用了mybatis框架&#xff0c;因此自然的用到了代码生成工具mybatis-generator-core-1.3.2.jar。我们一开始的做法是配置好generatorConfig.xml文件后&#xff0c;打开cmd命令窗口进入到生成文件所在的子项目目录中&#xff0c;执行命令&#xff1a; mvn mybatis-gen…